Not cycling with subs

Moderators:gds, bakerjw, renegade

Post Reply
Maflynn06
New Member
Posts:1
Joined:Tue Nov 08, 2022 4:48 pm
Not cycling with subs

Post by Maflynn06 » Tue Nov 08, 2022 5:33 pm

This is my first 300 blackout AR pistol, my first suppressor and my first post here so take it easy on me lol.

Here is my setup:
Palmetto State Armory 7.5” AR
Pistol Length Gas system
2.9 ounce Carbine Buffer
Riflespeed adjustable gas block.
Suppressor: Dead Air Wolfman with Micro Brake
Ammo Subsonic: Sellier & Bellot 200gr FMJ
Ammo Supersonic: Sig Sauer 125gr FMJ

On setting 4 on the gas block, the Supersonics were running beautifully. 100 rounds and not one malfunction. Subsonic rounds will not cycle or lock the bolt open no matter what 1-12 setting I was on. Gun sounds very weak and almost no recoil at all. My thought was getting a weaker spring but wanted those with more experience to chime in.

I am here to learn!

BulletFlight for Android
BJK
Silent But Deadly
Posts:279
Joined:Thu Jun 18, 2020 8:30 am

Re: Not cycling with subs

Post by BJK » Wed Nov 09, 2022 12:38 am

FWIW they won't cycle my AR either. That's why I reload. Yeah, I know not very helpful. I want to get a barrel for my Encore then a whole world of loads opens up.

Maybe someone will have something for your AR.

cdl
Senior Silent Operator
Posts:113
Joined:Thu Sep 15, 2016 2:30 am

Re: Not cycling with subs

Post by cdl » Fri Nov 11, 2022 4:09 pm

My RifleSpeed is the least efficient AGB I’ve ever tried. Great if you’re taming a Lion but a little too much for a mouse. I love it on my 308 and I’ve gotten it to work reliably with A1680 powder on 300 Blk. It’s probable not the best for playing the edges of quiet with custom or light loads. Take that, add a 7.5” barrel with little dwell time, a mellow load and a new gun with tight rings and a stiff new spring and the whole universe is throwing hate at you.

I’d throw on a standard straight through gas block and see if you have a chance. If it does everything you want with that load except lock back, say when it’s dirty, you could tweak the port size few sizes. There is something about knowing where a standard configuration running a standard factory load is at. It’ll serve as a baseline for all the crazy things you can try in the future. If that doesn’t work, it’s probably time to load your own. Crazy comes with the journey.

I have to add, running a carbine buffer, standard spring and stock bolt carrier is like wearing tennis shoes. Everything is snappy and responsive. Almost like that balance was by design. Wearing boots or flip-flops do have their place, but bring disadvantages too.

ReadyAimDuck
Silent But Deadly
Posts:155
Joined:Tue Jul 14, 2020 11:08 am

Re: Not cycling with subs

Post by ReadyAimDuck » Sat Nov 12, 2022 10:19 am

I would recommend you find out if your AGB has a narrower diameter opening at its max open setting than the gas port in your barrel before going through the hassle of replacing it with a standard block, especially when others have had issues with that factory load.

The first thing I would do is try a different subsonic load and send us your updates.

User avatar
dellet
Silent But Deadly
Posts:6798
Joined:Fri Nov 30, 2012 1:25 pm

Re: Not cycling with subs

Post by dellet » Sat Nov 12, 2022 11:45 am

With that many modifications to a rifle that still does not cycle, I would strip it down and start over.

It’s always possible that it was a bad lot of ammo, but a rifle that won’t cycle a commercial sub load, suppressed, with a buffer that is half the weight it should be sounds like more or a poorly constructed gas system.

Other ammo might solve the symptom, but there rifle will always be suspect.
300 Blackout, not just for sub-sonics.

cdl
Senior Silent Operator
Posts:113
Joined:Thu Sep 15, 2016 2:30 am

Re: Not cycling with subs

Post by cdl » Mon Nov 14, 2022 2:01 am

Don’t forget the RifleSpeed has a second level of rotation. 13 to 24 per say. It might not positively lock/click without a spacer on the split spring though. Open her way up if you want.

I wasted a lot time. Had that thing on and off half a dozen or more times and I was running suppressed, with an empty buffer, 0.110” gas port, a worn-out recoil spring and I had another inch of barrel. It’s fine with a 220gr bullet and 10.4gr of A1680, I didn’t even need to cheat, but chokes on a 237gr bullet and 9.5gr IMR4227 and all the cheating I could think of. Both loads produce about the same velocity, just over 1000fps, but 9.5gr is quieter than 10.4gr.

I prefer quieter. So I put my Superlative back on and life is good for me again.

One AGB uses a smooth pin that plunges in or out, the other uses a threaded set screw. One has blow-by, one really doesn’t.

Seems kind of silly to waste $200 on a setup that’ll probably not run that ammo with a $30 block either.

I think the Riflespeed is a really cool AGB. On the right gun. I own two of them.

Post Reply