DeadAir Keymo/Nomad Ti problem

Moderators:gds, bakerjw, renegade

Post Reply
3IfByAir
New Member
Posts:9
Joined:Fri Feb 14, 2020 10:44 am
DeadAir Keymo/Nomad Ti problem

Post by 3IfByAir » Tue Nov 23, 2021 4:02 pm

So I recently got my brand new suppressor out of jail and can’t wait to shoot it. I’m a first timer in this area. It’s a DeadAir Nomad-30 Ti for a 300 SBR. I’ve also got the keymo adapter mount on it as well. I followed all instructions to a T when mating the keymo to the suppressor. However, a small issue I’ve run into that kind of worries me is that after I’ve ratcheted the whole thing onto the host (hand tight) as I start to unscrew it instead of it ratcheting back off the host instead the suppressor will just start to unscrew itself from the keymo. Then the keymo will be sitting all by its lonesome on the host.

My question is: can I use rocksett or something similar to bond the suppressor to the keymo adapter? I understand it’ll have to be something that can hold up to extreme heat, and also probably won’t be able to take the two apart in the future.

BulletFlight for Android
bearcatrp
Silent But Deadly
Posts:422
Joined:Tue Jul 25, 2017 9:31 am

Re: DeadAir Keymo/Nomad Ti problem

Post by bearcatrp » Sun Nov 28, 2021 10:42 pm

I have the sandman s and use that adapter. I learned the hard way using rocksett. Bitch to get off if needed. Use blue or red lock tight. Just a couple drops at beginning of threads. Will spread as you tighten. Let it set at least 24 hours. Am using the blue stuff. Never an issue.

3IfByAir
New Member
Posts:9
Joined:Fri Feb 14, 2020 10:44 am

Re: DeadAir Keymo/Nomad Ti problem

Post by 3IfByAir » Sun Dec 19, 2021 1:49 pm

Awesome, thanks!

User avatar
bangbangping
Silent But Deadly
Posts:2651
Joined:Sun Sep 15, 2013 6:34 pm
Location:Texas Gulf Coast

Re: DeadAir Keymo/Nomad Ti problem

Post by bangbangping » Sun Dec 19, 2021 4:14 pm

Or...toss the adapter and [gasp!] direct thread to the barrel. Maybe there's something wrong with me, but I've never seen the need to spend a few hundred dollars to add weight, length, complexity, and more opportunity for something to go wrong.

2BearArms
Silent Operator
Posts:55
Joined:Thu Aug 23, 2012 11:53 pm
Location:SW CT

Re: DeadAir Keymo/Nomad Ti problem

Post by 2BearArms » Sun Dec 26, 2021 6:16 pm

3IfByAir wrote:
Tue Nov 23, 2021 4:02 pm
So I recently got my brand new suppressor out of jail and can’t wait to shoot it. I’m a first timer in this area. It’s a DeadAir Nomad-30 Ti for a 300 SBR. I’ve also got the keymo adapter mount on it as well. I followed all instructions to a T when mating the keymo to the suppressor. However, a small issue I’ve run into that kind of worries me is that after I’ve ratcheted the whole thing onto the host (hand tight) as I start to unscrew it instead of it ratcheting back off the host instead the suppressor will just start to unscrew itself from the keymo. Then the keymo will be sitting all by its lonesome on the host.

My question is: can I use rocksett or something similar to bond the suppressor to the keymo adapter? I understand it’ll have to be something that can hold up to extreme heat, and also probably won’t be able to take the two apart in the future.
It has been a while since I have been on here so I only just saw your post. I have a Dead Air KeyMount Muzzle Brake on a few different firearms and I also have a Nomad30 with the Keymo on it. I have the Muzzle Brakes Rockset to the barrels but I don’t have any thread locker on the junction of the Nomad and the Keymo adapter. If it is unscrewing on you, you don’t have the Keymo adapter tightened down enough to the Nomad. I would strongly suggest that you call or email Dead Air and talk to them about the best way to deal with this. The 2 wrenches that come with this setup should allow you to tighten it down enough to keep in from unscrewing as you described. I also have a Sandman K and that has the Keymo built into it. I really like this quick mount and dismount method.

Post Reply