Having function troubles with subsonic ammo

Moderators: gds, bakerjw, renegade

Post Reply
BustedGizmo
New Member
Posts: 1
Joined: Sat Aug 10, 2019 1:25 pm

Having function troubles with subsonic ammo

Post by BustedGizmo » Sat Aug 10, 2019 1:39 pm

Hi I was hoping for input. I’m having trouble getting my bolt to lock back on my 300black lantac enhanced bcg seekins adjustable gas block and a JP silent capture buffer h2 with green spring when using lighter spring will not cycle. The gas block is all the way open and even with sico omega can will not lock back. Anybody have any suggestions on what I’m missing. Also it is just with subs suppers are working
And it is a pistol length gas system

BulletFlight for Android
tallburnedmidget
Silent But Deadly
Posts: 3801
Joined: Wed Jun 13, 2012 9:01 pm

Re: Having function troubles with subsonic ammo

Post by tallburnedmidget » Sat Aug 17, 2019 8:48 pm

BustedGizmo wrote:
Sat Aug 10, 2019 1:39 pm
Hi I was hoping for input. I’m having trouble getting my bolt to lock back on my 300black lantac enhanced bcg seekins adjustable gas block and a JP silent capture buffer h2 with green spring when using lighter spring will not cycle. The gas block is all the way open and even with sico omega can will not lock back. Anybody have any suggestions on what I’m missing. Also it is just with subs suppers are working
And it is a pistol length gas system
Hi there and welcome!

With those symptoms a couple of things come to mind.

What ammo are you using, store bought or handloaded?
-If handloads what powder, charge, coal, bullet, etc. are being used? (basically the entire round recipe plus velocity if you have it)


After ammo the only thing that comes to mind is that your gas block may not be properly aligned.
Maybe the barrel gas port (hole) and the gas block port (hole) are off just enough that your subs are having issue.


Ammo is easier to troubleshoot than taking apart and checking the gas block and barrel alignment so let us know all you can about the ammo :)

Boolit_Head
Silent But Deadly
Posts: 349
Joined: Tue Aug 23, 2016 7:15 pm

Re: Having function troubles with subsonic ammo

Post by Boolit_Head » Sun Aug 18, 2019 9:07 pm

Usually you adjust gas with a gas block and not a H2 buffer at the same time. Try a standard buffer. It seems like you don't have enough gas to move that mass.

User avatar
Dolomite_Supafly
Silent But Deadly
Posts: 3017
Joined: Fri Oct 30, 2009 7:03 am
Location: East Tennessee
Contact:

Re: Having function troubles with subsonic ammo

Post by Dolomite_Supafly » Tue Aug 20, 2019 5:05 am

With an adjustable gas block you can use lightweight parts. No need to run a heavy buffer. Use the adjustable gas block to tune the cycling instead of the buffer.
WWW.thegunmilitia.com

Come join the militia!

Post Reply